[COCI2017-2018#5] Pictionary

题面翻译

题目描述

在宇宙一个不为人知的地方,有一个星球,上面有一个国家,只有数学家居住。
在这个国家有\(n\)个数学家,有趣的是,每个数学家都住在自己的城市,且城市间无道路相连,因为他们可以在线交流。当然,城市有从\(1\)\(n\)的编号。

一位数学家决定用手机发论文,而手机将“不言而喻”自动更正成了“猜谜游戏”。
不久之后,这个国家就发现了猜谜游戏。他们想要见面一起玩,于是这个国家就开始了修路工程。
道路修建会持续\(m\)天。对于第\(i\)天,若\(\gcd(a,b)=m-i+1\),则\(a\)\(b\)城市间会修一条路。

由于数学家们忙于建筑工作,请你来确定一对数学家最早什么时候能凑到一起玩。

输入输出格式

输入格式

第一行有三个正整数\(n,m,q\),表示城市数量、修路持续天数、询问数量。
接下来\(q\)行,每行有两个正整数\(a,b\),表示询问\(a\)\(b\)两个城市的数学家最早什么时候能在一起玩。

输出格式

输出\(q\)行,第\(i\)行有一个正整数,表示第\(i\)次询问的结果

说明

数据范围:
对于\(40\%\)的数据:
\(n≤4000,q≤10^5\)
对于全部数据:
\(1≤n,q≤10^5\)
\(1≤m≤n\)

样例1解释:
在第一天,\((3,6)\)之间修了一条路,因此第二次询问输出1
在第二天,\((2,4),(2,6),(2,8),(4,6),(6,8)\)之间都修了一条路,此时\(4\)\(8\)号城市连通,第三次询问输出2
在第三天,所有编号互质的城市之间都修了路,\(2\)\(5\)号城市在此时连通,第一次询问输出1

样例2解释:
在第二天,\((20,15)\)之间修了一条路
第四天,\((15,9)\)之间修了一条路
所以\(20\)\(9\)号城市在第四天连通,输出4

题目描述

There is a planet, in a yet undiscovered part of the universe, with a country inhabited solely
by mathematicians. In this country, there are a total of ​N mathematicians, and the interesting
fact is that each mathematician lives in their own city. Is it also interesting that no two cities
are connected with a road, because mathematicians can communicate online or by
reviewing academic papers. Naturally, the cities are labeled with numbers from 1 to ​N.

Life was perfect until one mathematician decided to write an academic paper on their
smartphone. The smartphone auto-corrected the word “self-evident” to “Pictionary” and the
paper was published as such. Soon after, the entire country discovered pictionary and
wanted to meet up and play, so construction work on roads between cities began shortly.
.
The road construction will last a total of ​M days, according to the following schedule: on the
first day, construction is done on roads between all pairs of cities that have ​M as their
greatest common divisor. On the second day, construction is done on roads between all
pairs of cities that have ​M-1 as their greatest common divisor, and so on until the ​\(M^{th}\) day
when construction is done on roads between all pairs of cities that are co-prime. More
formally, on the \(i^{th}\) day, construction is done on roads between cities ​a and ​b if ​gcd(a, b) = \(M-i+1\).

Since the mathematicians are busy with construction work, they’ve asked you to help them
determine the minimal number of days before a given pair of mathematicians can play
pictionary together.

输入格式

The first line of input contains three positive integers ​N, M
and ​Q
(1 ≤ ​N
, ​Q ≤ 100 000, 1 ≤ ​M
≤ ​N
), the number of cities, the number of days it takes to build the roads, and the number of
queries.

Each of the following ​Q lines contains two distinct positive integers ​A and ​B
(1 ≤ ​A
, ​B ≤ ​N
)
that denote the cities of the mathematicians who want to find out the minimal number of days
before they can play pictionary together.

输出格式

The \(i^{th}\) line must contain the minimal number of days before the mathematicians from the \(i^{th}\) query can play pictionary together.

样例 #1

样例输入 #1

8 3 3
2 5
3 6
4 8

样例输出 #1

3
1
2

样例 #2

样例输入 #2

25 6 1
20 9

样例输出 #2

4

样例 #3

样例输入 #3

9999 2222 2
1025 2405
3154 8949

样例输出 #3

1980
2160

提示

In test cases worth 40% of total points, it will hold ​N
≤ 1000, ​Q
≤ 100 000.

Clarification of the first test case:

On the first day, road (3, 6) is built. Therefore the answer to the second query is 1.

On the second day, roads (2, 4), (2, 6), (2, 8), (4, 6) and (6, 8) are built. Cities 4 and 8 are now
connected (it is possible to get from the first to the second using city 6).

On the third day, roads between relatively prime cities are built, so cities 2 and 5 are connected.

Clarification of the second test case:

On the second day, road (20, 15) is built, whereas on the fourth day, road (15, 9) is built. After the
fourth day, cities 20 and 9 are connected via city 15.

审题

题意转化:

\(n\)座城市;
\(m\)个时刻,在第\(i\)个时刻,所有\(m-i+1\)的倍数之间连边;
\(q\)个询问,询问第\(x_i\)座城市和第\(y_i\)座城市什么时候连通。

连边(合并)

连通城市的过程,其实就是对多个点建立集合,并进行合并的过程,所以考虑使用并查集

在对两个城市进行连边(即合并两个点)时,钦定第一个城市是第二个城市的父亲节点,并记录这两个点合并时的时间戳。

查询

现询问两个点\((x,y)\)的最早连通时间。\((x,y)\)的最早连通时间就是\(x\)\(lca(x,y)\)中的最大时间戳加上\(lca(x,y)\)\(y\)中的最大时间戳。

为什么是最大值?
两个城市要想连通,就必须要等到路径上最后一条边建好才行。

为什么是\(lca\)
题目中城市\(x\)和城市\(y\)的连通抽象到图上就是\(x\)\(y\)的一条树上路径(同一条边不能重复走),也就是\(x\)->\(lca(x,y)\)->\(y\).这里不能包含\(lca(x,y)\),因为这个点储存的时间戳是和另一个点击合并的时间。

考虑\(lca\)的求法。在处理并查集的时候,其实就处理出的图上的每一个父子关系,我们可以将其利用起来:根据这些父子关系,\(x\)\(y\)往上跳,从而找到\(lca(x,y)\).

但要想保存父子关系就不能使用路径压缩,所以采用启发式合并:将小集合合并到大集合,以起到优化的作用。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;
const int N=100010;
int n,m,q;
int f[N],siz[N],dfn[N],dep[N]; 
struct Edge//链式前向星存图 
{
	int u,v,nex;
}e[N<<1];
int head[N],tot;
void add(int u,int v)
{
	tot++;
	e[tot].u=u;
	e[tot].v=v;
	e[tot].nex=head[u];
	head[u]=tot;
}
int maxx(int a,int b)
{
	return a>b?a:b;
}
int find(int x)//并查集查找(不能用路径压缩) 
{
	if(x==f[x]) return x;
	return find(f[x]);
}
void dfs(int u)//dfs求每个点相对于超级祖先的深度 
{
	for(int i=head[u];i;i=e[i].nex)
	{
		int v=e[i].v;
		dep[v]=dep[u]+1;
		dfs(v);
	}
}
int main()
{
	scanf("%d%d%d",&n,&m,&q);
	int rt;
	for(int i=1;i<=n;i++)
	{
		f[i]=i;
		siz[i]=0;
	}
	for(int i=m;i>=1;i--)
	{
		for(int j=(i<<1);j<=n;j+=i)//对所有m-i+1的倍数之间连边 
		{
			int dx=find(i),dy=find(j);
			if(dx==dy)
			{
				continue;
			}
			if(siz[dx]<siz[dy])//启发式合并,将小集合合并到大集合 
			{
				swap(dx,dy);
			}
			f[dy]=dx;
			add(dx,dy);
			rt=dx;//rt最终会记录所有点的公共祖先,钦定这个“超级祖先”为根节点 
			if(siz[dx]==siz[dy])
			{
				siz[dx]++;
			}
			dfn[dy]=m-i+1;//dfn记录合并时的时间戳 
		}
	}
	dfs(rt);
	for(int i=1;i<=q;i++)
	{
		int x,y;
		scanf("%d%d",&x,&y);
		int ans=0;
		if(dep[x]<dep[y])
		{
			swap(x,y);
		}
		while(dep[x]>dep[y])
		{
			ans=maxx(ans,dfn[x]);
			x=f[x];
		}
		while(x!=y)
		{
			ans=maxx(maxx(dfn[x],dfn[y]),ans);
			x=f[x],y=f[y];
		}
		printf("%d\n",ans);
	}
}

参考

原文地址:http://www.cnblogs.com/fish4174/p/16846368.html

1. 本站所有资源来源于用户上传和网络,如有侵权请邮件联系站长! 2. 分享目的仅供大家学习和交流,请务用于商业用途! 3. 如果你也有好源码或者教程,可以到用户中心发布,分享有积分奖励和额外收入! 4. 本站提供的源码、模板、插件等等其他资源,都不包含技术服务请大家谅解! 5. 如有链接无法下载、失效或广告,请联系管理员处理! 6. 本站资源售价只是赞助,收取费用仅维持本站的日常运营所需! 7. 如遇到加密压缩包,默认解压密码为"gltf",如遇到无法解压的请联系管理员! 8. 因为资源和程序源码均为可复制品,所以不支持任何理由的退款兑现,请斟酌后支付下载 声明:如果标题没有注明"已测试"或者"测试可用"等字样的资源源码均未经过站长测试.特别注意没有标注的源码不保证任何可用性