给定一个数列 \(a= { a_1,a_2,…,a_n }\) 以及 \(q\) 次查询。
其中第 \(i\) 次查询如同:\(l_i, r_i\),意指求 \(\sum_{j=l_i}^{r_i} {a_j}\)
但是查询前可以对数列任意排序,使得查询结果的和最大,问最大的和是多少。

Input

\(1\)\(n,q\)
\(2\)\(a_1, a_2, …, a_n\)
接下来 \(q\) 行,每行 \(2\) 个整数 \(l_i,r_i\)

数据范围:\(1≤n,q,a_i≤2·10^5,1≤l_i≤r_i≤n\)

Output

最大的和

Sample Input

3 3
5 3 2
1 2
2 3
1 3

Sample Output

25

分析

image

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N=1e6+10,INF=0x3f3f3f3f;
int n,m,a[N],b[N];
LL res=0;

//#define local
int main() {
#ifdef local
    freopen("data.in", "r", stdin);
//    freopen("data.out", "w", stdout);
#endif

    int n,q; scanf("%d%d",&n,&q);
    for(int i=1; i<=n; i++) scanf("%d",&a[i]);
    int l,r;
    while(q--) {
        scanf("%d%d",&l,&r); b[l]++, b[r+1]--;
    }
    for(int i=1; i<=n; i++) b[i]+=b[i-1];

    sort(a+1, a+1+n); sort(b+1, b+1+n);
    for(int i=1; i<=n; i++) res += 1ll*a[i]*b[i];
    printf("%lld\n",res);
    return 0;
}

原文地址:http://www.cnblogs.com/hellohebin/p/16879718.html

1. 本站所有资源来源于用户上传和网络,如有侵权请邮件联系站长! 2. 分享目的仅供大家学习和交流,请务用于商业用途! 3. 如果你也有好源码或者教程,可以到用户中心发布,分享有积分奖励和额外收入! 4. 本站提供的源码、模板、插件等等其他资源,都不包含技术服务请大家谅解! 5. 如有链接无法下载、失效或广告,请联系管理员处理! 6. 本站资源售价只是赞助,收取费用仅维持本站的日常运营所需! 7. 如遇到加密压缩包,默认解压密码为"gltf",如遇到无法解压的请联系管理员! 8. 因为资源和程序源码均为可复制品,所以不支持任何理由的退款兑现,请斟酌后支付下载 声明:如果标题没有注明"已测试"或者"测试可用"等字样的资源源码均未经过站长测试.特别注意没有标注的源码不保证任何可用性